Cannot program ESP32DEVC on either Mac or Windows


#1
  • Followed tutorial to a T.

  • Tutorial program builds using Chrome on both Windows 7 and Mac OS 10.12.6 Sierra

  • Downloaded atmoAgent on both machines for their appropriate OS

  • On Mac, Agent open and running in background. ESP32DEVC plugged into USB. Refreshed / loaded atmo Platform (as I’ve read here, agent must be open first before loading platform or refreshing browser). Click on program firmware. Absolutely nothing happens. Nothing.

  • On Windows machine, click to install Agent. Sexy coding graphics run for about a minute then disappear, then nothing.

  • No sign of Agent anywhere in list of programs. Cloud image not in tray (As I’ve read here it should be)

  • ESP32DEVC plugged into USB. Built / refreshed / loaded atmo Platform. Click program firmware.

  • Clicking program firmware results in a download of the firmware. From reading here it’s because agent is not running. Can’t find agent anywhere on this Windows machine, like it was never installed.

  • suspected ESP32DEVC board was damaged or malfunctioning so I bought another one off Amazon for $10. Same.

Seems others here have gotten further than I have and have actually been able to connect the board to a mobile device but I can’t even seem to get off the launch pad. Had great success with Anaren Atmosphere for several years. I realize you guys are just getting this off the ground and you’re probably pulling your hair out like I am. Poking about, I see there is not yet a module for PWM which would be my primary application. Any advice or suggestions would be greatly appreciated, I know you are working hard on it…thanks much !


#2

@LoTek - To test if I can figure out where the issue is, I just unplugged my ESP32 and hit the download icon and it popped up the Program Firmware dialog box as I would expect, so the issue is related to the Agent, not the ESP32.
Unfortunately I’m running Win 10, so I can’t try to replicate you issue directly. When I open the Task Manager, the Agent shows up not as a Main Process (like Chrome or Word), but as a Background Process. A Cloud Icon also appears in the tray. Which browser are you using on PC?

Is there a chance your browser is blocking the pop up? Hopefully someone with a Win 7 machine can weigh in on how/where the Agent appears.


#3

PWM is slated for the next release, it’s there but not exposed via an element yet.

As for your agent issues it’s very odd what you are reporting if I am correct is that you click the program firmware icon in the Embedded tab and then you don’t get the programming dialog on Mac OSX? And on Windows you don’t seem to get the Agent running at all.

If you could attach a link to the tutorial you are mentioning so we can reference it will help us keep track of what we are talking about.

Could you tell us what browser you are currently using and what version it is? If you’ve tried other browsers that would be helpful to know as well.

I would recommend trying a couple of things. On Windows try running the agent in administrator mode and see if that gets it to run. If it’s running correctly you should get a system tray icon.

For Mac OSX I would like to know if you could run the following command while the device is plugged in. So while the device is plugged in over USB open the terminal app and type ls /dev/tty* This will print out all the available serial ports on your device. Maybe it’s not getting loaded properly so the agent’s programmers don’t see it? If you can past the list of serial device here we might be able to get to the bottom of that issue.


#4

LoTek,

Did you ever figure out what the problem was? I’m also unable to program an ESP32 and would love it if you shared your solution if any.

Thanks in advance!


#5

Hello Walter,
No I have not been successful, but then I haven’t tried any of the suggestions offered by svenrichard or Kieron.gillespie. I did try loading agent on my wife’s PC running Windows 10 and it does the exact same thing. Agent looks like it’s installing, then disappears and I cannot program the ESP32DEVC board on her computer as well. Also, I have maybe four or five USB cables I have tried and I’m wondering if all of these are just charge cables as opposed to cables that actually carry data. They all have the USB logo printed on the “A” side but I’ve read this is no guarantee that they are actually data cables. Could that be the issue ? I will try again but I have kind of moved on.


#6

Well I was experiencing the same EXACT problem as you, and thought that, since you never replied to Kieron, that maybe you had already figured out the problem.

That being said…

I have since, with Kieron Gillespie’s and Richard LaBore’s help, been able to program my Feather Huzzah32 using a Windows 10 machine.

Here’s what I did:

  1. Downloaded and Installed Agent on my system. I ran the executable as Administrator.
    After installation, Agent shows up in my control panel / programs and features as: Atmosphere IoT Agent

Note: The installation is kind of weird… This weird box pups up, and you can see parts moving inside. There’s really no status bar, or any kind of indication that it’s running other than the icon on the main bottom toolbar is slowly filling up. (Don’t know if that makes sense) It takes a while, but once it’s done loading, the weird box goes away, and the cloud icon Does appear in my system tray.

Important Note: There was NO icon created on my Desktop for the Agent, and couldn’t find a folder containing an executable to run agent from. At least for me, I have to reinstall Agent to be able to use it, which is kind of a drag.

  1. Once the Agent is installed and appearing in my system tray, From the System Tray, I Right Clicked on the Icon, and Click Developers. This brings up the Atmosphere Developer Hub.

  2. I log in to: Atmosphere IoT Platform (Beta) FROM HERE
    NOTE: Kieron pointed out that I needed to have the Agent running and AFTER it was running, ONLY then log in to the IoT platform. This did the trick for me.

  3. When I click on Program Firmware (eeprom looking icon) from Embedded View, I actually get a serial connection menu where I can select a com port and baud rate.

  4. Blinked the Red LED on my huzzah!!

For a while there, I was ready to start breaking things… Took a breather… Tried again…

I hope this helps…