Device registration information not valid


#1

Hi Guys,

When I was provisioning my device, I got this error on my phone:

“Device registration information not valid”

Does anyone know why this happens?

Thanks!
Danwei


#2

@danwei - are you using Android? Which Kit are you using?
Thanks


#3

Hi @svenrichard

My phone is Android and I’m using NXP Rapid IoT Kit.
This issue didn’t happen before until last week.

Best regards,
Danwei


#4

@danwei - we are working on improving Android connectivity for our next release. It should be available by next week.


#5

Hi @svenrichard

Thanks for the help!
But I tried the latest release 1.1.8 today, and it still cannot provision my device. It will have error:
“Unable to authenticate device’s hardware credentials”

What should I do to fix it?

Best regards,
Danwei


#6

@danwei - Please specify the Model and Android version of your phone. This will help us diagnose the issue.
Did you get your Rapid IoT kit through Distribution, or was it one from NXP? If it was an early prototype, we may be chasing a manufacturing issue and not something that either of us can fix.

Also please verify if you are using the Rapid IoT Studio or if you are using the Atmosphere IoT Platform.

Thanks


#7

We would like you try one thing first.

1.) Make sure you completely close out of the app on your android device
2.) Go to the “Settings” on your Android device
3.) Go to “Apps” and then locate the NXP Rapid IoT app. Click on it to open the app settings
4.) You should then see an option for “Storage” go into there and then click “Clear Cache”.
5.) After you do that reopen the app and try again and let us know what happens


#8

Hi Kieron,

Thanks for the suggestion.
I followed your guide and cleared the cache, but the issue is still the same.

Best regards,
Danwei


#9

Hi @svenrichard,

My phone is Xiaomi 5s plus with Android N 7.0.
I’m a system engineer from NXP, so my Rapid IoT kit is from NXP directly. I got the kit in June 10, not sure if it’s early prototype.
However the issue seems not hardware related, because if I reduced the number of BLE characteristics in my project, then I can provision my device normally. Right now I have about 18 BLE characteristics. I heard that one service UUID can only support 10 BLE characteristics, so I used 2 service UUID which is randomly generated. Is there any special rules for service UUID?
Besides that, I didn’t do anything special. ( If it helps, I can also provide my .atmo file, but seems cannot attach here)

I used Rapid IoT Studio with 1.1.4 App, and Atmosphere IoT Platform with 1.1.8 App, the issue is the same.

Thanks!

Best regards,
Danwei


#10

Same issue for me… My phone is a Ulefone Paris. Have some solution? with the 1.1.8 version


#11

@kelu28 - can you tell me how many BLE characteristics you have in your project? And what version of Android your phone is running?
Thanks


#12

The root cause of this issue has been identified as a hard coded limit in the KW41Z firmware. We are working to get that changed and will work with the Rapid IoT team to get a fix and an explanation distributed as soon as possible. Thanks


#13

Thanks, svenrichard. Looking forward to the final solution.

Best regards,
Danwei


#14

The solution from NXP will be new FW for the KW41Z. This will be released by them, and it will need to be loaded into the Rapid IoT Kit following the instructions in their getting started guide. The FW will be taqged in the file for the KW41Z so it is the same process as loading a new project, the Rapid IoT Kit bootloader will put it in the right microcontroller. We have tested a release candidate, we will notify the forum when it is available.
Thanks


#15

Thanks!I already got the new FW for the KW41Z internally and has verified that it will solve the issue.

Best regards,
Danwei