ESP32 Device NOT detected


#1

atmosphereiotagent is installed an runnning.

Feather Huzzah32 connected to Mac running OS Mojave v.10.14.1

Using SAFARI,

From platform.atmosphereiot.com / Devices menu

When I click on “+” sign it says I have NO devices.

Do I need to add drivers so device is detected on USB port?
I have no clue…
Thanks in advance for all your help.


#2

@Walter - You need to hit the + button from the Atmosphere mobile app to provision a new BLE device. I’d recommend the Introduction to Atmosphere video series for more help getting started.


#3

Richard,

Thank you for the quick response!

I downloaded the Atmosphere iPhone App.

Huzzah32 is plugged in - Two LEDs flashing. Yellow - flashing quickly, Red - flashing slowly

From iPhone App - I Clicked on hamburger, then box, then “+”

App Says searching for available devices… After a few secs it says searching complete. No available devices.

I thought maybe an issue with driver, so I installed CP210x USB to UART Bridge VCP Drivers for Mac OS - Same result…

Also, when following the intro series video 3, it says to click on PROGRAM FIRMWARE button to flash the board. In the video, a popup windows appears with com port options.

On my end, whenever I click on the Program Firmware button, it downloads the file instead.

Any other ideas??

Thanks again for all your help.


#4

@walter - if you get a .zip file instead of the serial connection, there is an issue with the Agent connecting to the kit. I’m not a mac guy, so hopefully one of those guys can chime in. I’m pretty sure there is a post down a few topics that used the Espressif programmer to successfully load the code on the kit. If the Red LED is blinking - you created Blinky properly. The Yellow LED always blinks fast, the Red one is the one you control with the GPIO element.


#5

To program the device with Atmosphere IoT you must first install the Client Agent for your particular system and then have it running when you load the website.

You can find instructions for getting started in our developer docs area.
https://developer.atmosphereiot.com/documents/guides/gettingstartedesp32.html


#6

The Red led blinked slowly out of the box - I never was able to flash anything to the ESP32 at any point.

Also, I tried running platform from a windows machine, and got a zip file instead of a serial connection when I tried to program firmware into device - Which is weird, because a while back, I flashed an Anaren board using the same windows machine without a hiccup . Many things have changed since those days…

Thank you Richard LaBorde for your continued support.

On another note, I did not know that there’s a sequence of events: Have the Agent running BEFORE logging in to Platform - If I remember correctly, in all my attempts, i was always logged on to platform BEFORE I started Agent.

Thank you Kieron Gillespie for that bit of info! I will give it a try as soon as I’m in front of my computer.

Thanks again in advance for everyone’s help and support.


#7

@Walter - the instructions for using the ESP tools are in this post - Use esptools for Esp32 instead of Atmosphere Iot Agent
Thanks