ESP32 DevKit C - Unable to program firmware

Newbie issue. Probably hardware related but I thought I’d take a shot and ask.

I have an ESP32 DevKit C hooked to my computer via USB to program the firmware. Program compiled successful. Clicked Program Firmware icon but Serial Port shows “No available options.”

The Atmosphere IoT Agent is running in the background before I even pulled up the web browser to do this. Tried on multiple browsers, multiple computers, multiple OS, and multiple ESP32’s, multiple cables and come up with the same “No available options.”

Tried programming regardless to no avail.

Thoughts?..and thanks for your time.

1

Hi,

Have you installed the drivers for your ESP32? I would recommend going through and following this part of the Espressif guide: https://docs.espressif.com/projects/esp-idf/en/latest/esp32/get-started/establish-serial-connection.html

-Nick

Nick,

Brilliant!!! Long story short, I didn’t have the Driver installed. Thank you THANK YOU NICK.

But wait, that’s not all.

Long story: I installed the driver and it didn’t work. Other computers, the same. Then I discovered that my Device Manager “Ports (COM & LPT)” was missing. Added Legacy Hardware via “Action” menu. Computer still didn’t recognize the hardware. Hmmm. Went through 2 USB cables, but I tried a 3rd. That finally worked.

In Summary:
Had I used the right USB cable, my computer would have gently led me to the light and the need for a driver. Never use the charge-only type USB.

Thank goodness for Nick.crast. As always I do everything backwards the first go.