ESP32 loss of BLE functionality


#1

I’ve recently attempted to recreate the ESP32 demo example with the new platform 1.2.

The embedded code seems to be running - as I can see action on the GPIOs and I even had the UART working.

The application seems to work with the exception that no data seems to be transferred up through the bluetooth element from the embedded ESP32 Dev Kit Revc.

Anybody else having similar problems? I tried on both on an old iphone 5C and new iphone X. Are there any demos I could use to test my setup?


#2

@dpESP32user - try going back to devices and choosing that device a second time. See if the app connects.


#3

Today I went back in and the device connected and it worked as expected!
The embedded device had been powered down and back. The atmosphere app had been closed and then reopened. I thought I had attempted all this before asking for help too though.
I had noticed the embedded device had no issues initially provisioning but on the first attempt to see the application there was no Bluetooth symbol in the lower right of the application view. On the next attempt to see the application the Bluetooth symbol in the lower right was flashing/blinking. Now with the application working correctly the Bluetooth symbol is constantly on.
I also initially “cancelled” out of the WiFI setup.
Are there some rules (order) or steps to do this corectly?
Thanks


#4

@dpESP32user - I think we have an issue in the App that when the WiFi configuration page comes up, the BLE connects and doesn’t release that connection for the main app to connect.

Working process: Provision device - Cancel WiFi configuration - Reboot kit - Connect to device
Any time you disconnect and reconnect after this should work properly.

We have noted this behavior and will address in the next release. Thanks!


#5

Thanks for the explanation and procedure!