Have there been significant changes to Atmosphere Studio recently?


#1

I started having a problem this afternoon using Rapid IoT Studio that seemed to happen all of a sudden. I was trying out the NFC Click demo and when I made some element changes, things stopped working. The program seems to compile fine but when I reflash the Rapid IoT it goes into a constant reboot cycle. If I use previously compiled programs they work fine, but if I try to recompile from the same source code it fails. I even tried recompiling some of the provided examples that had worked fine earlier. I tried using Atmosphere Studio and it failed the same way.

I actually was able to get it to fail using just a single Text Page element. It would work unaltered and also with a Page Title, but it would always fail when I entered even a single character into the Text field.

I noticed that the Mass-Storage Device window closes when it reboots. Previously when it was functioning normally the MSD window would stay open.

Not sure how to look for the problem. Have there been changes to both IDEs that might cause this type of problem?

Update 01/27/2019:
I assume that since no one else is complaining that this problem is isolated to me.
I recompiled the OOB Demo this morning and it worked correctly. Compiling other programs worked with the exception of the NFC Click Demo. Not sure what happened yesterday. I assume I corrupted one of the boot images.

The NFC Click Demo still causes the reboot problem and it does correlate to the text in the Text Page element. It will work if I delete that text. I have verified that on another computer and using another browser, so unless there is remote caching in the IDE, I guess I must have some kind of bizarre hardware problem on my device. Not sure why it would associate with the Text Page element and also this example used to work correctly. As a matter of fact an old binary still works.


#2

@ralphjy - could you post your .atmo file please? One of the developers can take a look more easily that way.
Thanks


#3

The problem occurs with the unmodified NFC Click demo that is in the Examples section. That used to work. It still compiles without complaining but causes reboots unless I remove the text on the Text page. If that works for you then I must have a strange
hardware or setup problem.

I’ve tried with just a single Text page and nothing else and it also has a problem with any text in the Text field. Doesn’t seem to matter what. Title field works okay. Seems like a pointer is messed up or something and that text is overwriting something
that causes a reboot - that’s only a guess, I don’t have a debugger.


#4

@ralphjy - Thanks - I was able to duplicate the reboot issue. You can now use the USB on the Rapid IoT as a Serial Debug, but the logs don’t show much useful at first glance. We will have a developer dig into it.
Thanks


#5

@ralphjy - Have you been able to resolve this with the update to the Text Element?


#6

Yes, thanks. I responded yesterday - I may only have done that on Hackster…

Just for interest sake - can you share what caused the problem?


#7

@ralphjy - it was a memory allocation issue - that’s why it still worked if you had a blank element. I’m not totally sure on the specifics.