Not able to program

I am trying to use PSoC 6 WiFi BT proto with atmosphere iot studio. I complied PSoC 6 WiFi BT proto and tried to program it by clicking the program button. But the program firmware window is not showing any progress and it is not programmed. kindly help me.

Hi,

What do you see if you click on “Show Advanced Output” on the “Program Firmware” dialog?

Nick

Thanks for getting back to me. Actually when pressed “show advanced output” nothing happens. It shows only “hide advance output”. I suspect it may be due to some firewall issue is it?. Any other points to be checked? 'Kindly guide me.

I don’t think it’s a firewall issue. If Atmosphere Studio wasn’t able to communicate with the Atmosphere IoT agent, you wouldn’t have gotten this far. What OS are you running?

You’re using the USB port labeled PROG/DEBUG on the long edge of the board, correct? NOT the USB port labeled PSOC 6 USB (Device). You want the one labeled PROG/DEBUG near the MicroSD slot.

Sir,
I am using windows 7. Atmosphere iot agent is also running. I connected the board with computer using micro usb connector from usb port of the board named “kit prog” and not at psoc 6 usb port.
Thanks
Gopal

Could you attach a screenshot or a video of the programming window? You’re seeing no output at all?

My work place is under lockdown. I try to send it to you when possible.
The problem is,
When pressed program button on the bar, the firmware dialog box appears and asks press program or cancel. On pressing program the firmware window is not showing any progress bar for programming status as shown in the demo youtube but lt shows active " show advanced program output" message only. On pressing “show advance program output” again no progress bar is appearing but it shows active “cancel” message only.
Thank you
Gopal

Sir,
As you asked I have attached both doc. and pdf of screen shots of firmware programming is attached. Hardware is attached in a USB port and in the hardware power led (LED1),status LED (2) and module power LED 3 are glowing. Kindly suggest me.
regards
gopal

(Attachment screen shots of firmware programming.docx is missing)

(Attachment screen shots of firmware programming (1).pdf is missing)

Gopala Krishnan <krishnanvgopala@gmail.com>

2:10 PM (23 minutes ago)

to Atmosphere

Sir,
As you asked I have attached both doc. and pdf of screen shots of firmware programming. Hardware is attached in a USB port and in the hardware power led (LED1),status LED (2) and module power LED 3 are glowing. Kindly suggest me.
regards
gopal

(Attachment screen shots of firmware programming.rar is missing)

screen shots of firmware programming (1).zip (1.4 MB)

Interesting. Can you try the following:

  1. Close IoT Agent
  2. Open up CMD or Powershell and start the IoT Agent via the command line. It will give you some verbose output that will be helpful for debugging. Typical install path is: “C:\Program Files\Atmosphere IoT Agent\Atmosphere IoT Agent.exe”.

Open IoT Agent this way and try the program again, and please send the output of the IoT Agent.

Thanks,
Nick

Sir
I Have attached the screen shots of the error message.
regards
gopal

(Attachment error1.rar is missing)

(Attachment error2.rar is missing)

@Gopalakrishnan - I think our settings were blocking .rar and .pdf extensions. Can you try sending those files again? Thanks!

JPEG image of error message is attached.
thanks
gopal

Hi,

Did that error appear on startup? Do you get any additional errors when you attempt to program?

-Nick

@Gopalakrishnan - With Microsoft officially EoLing Win 7 we are not doing testing on Win 7 anymore. Unfortunately that means the more releases we get from when we last tested it, the less likely it is that everything will still work. I wish I had better news for you.

The error appears during startup. But if I closes and opens IoT agent from program files it remains open and runs.