PIC IOT WG Atmosphere Agent - problem

Hello, i am a new user.
my PIC IOT WG board is not being detected by the Atmosphere Agent.
It shows up in my system tray, says that it is working properly.
I’ve loaded various demo code.
I’ve reloaded the original microchip code and the board works fine.
I’ve tried multiple computers and USB cables.
any suggestions?

Hello bmorrow,

Which operating systems and browsers have you tried?

If you are using Firefox, please make sure you add the security certificate exception as described here.
https://developer.atmosphereiot.com/documents/downloads/atmosphereiotagent.html#running-the-agent

I would recommend you refresh your browser then try to register the device again, while the Agent is running.

I am using a Google Chrome browser

when i check Atmosphere agent it says that it is running correctly but i get a ‘not secure’ warning

as i mentioned ive tried multple computers with the same results?

@bmorrow - to clarify - your device shows up as a CURIOSITY drive when you plug it in and you can drag and drop the .hex file to program it, you just aren’t successful in provisioning the device using the New Device button in the web interface?

thank you for checking back, i was able to resolve my issue by reinstalling the PIC IOT WG drivers, everything seems good now.
thanks again for the assistance.