ProgramFirmware Button Not working

Using Google Chrome, when I reach this step in the Getting Started Tutorial:

Return to Embedded View, and click the program firmware button in the view’s toolbar.
Under Device Port, select the communication port the end device is connected to.
Click Program to start programming. When complete, you’ll receive a notification stating the end device is programmed with the project’s embedded firmware.

When I press the ProgramFirmware button on my desktop, it downloads a zipfile with the program and a bootloader but no dialogue box opens. When I use my laptop, the button doesn’t do anything at all.

I am unsure if it is my browser or if the button just isnt functioning normally.

Am I supposed to do something with the zipfile?

Thank you,

Trent Storm

@tmstorm - we are working on a bug in the firmware programming process. A new version will be released soon. Thanks

Hi Richard, any update on this?

@tmstorm - a new version was released this weekend. We are looking into a persisting issue in the Program Firmware process in Windows. Are you using Linux or Windows?

A new version of the Windows agent will be on the Downloads page this afternoon. It has been tested with three different variants of the ESP32. It has been used to successfully program multiple variants. We recommend you uninstall the Current Agent, download and install the latest agent (ignore the security warning) and update your Atmosphere IoT App.

Also using Google Chrome and windows 10, for RSL10-SENSE-GEVK.

Trying to get this setup: https://developer.atmosphereiot.com/documents/guides/gettingstartedrsl10sensegevk.html
Have followed all the steps (incliding adding to path etc etc.) up until this one:

"With setup complete, you can program your board:

  1. While the Embedded tab is active, click the Program Firmware button from the tab’s toolbar. This displays the Program Firmware window…"

but unanble to get the Program Firmware button working on either my desktop or laptop - at times the button doesn’t do anything at all. while at times it says
“The Atmosphere Client Agent was not detected. Please start the Atmosphere Client Agent and try again” eventhough its running in the background.

Unsure if its to do with the security settings/certificate of https://localhost:48701/ on chrome? tried to add in the trusted sites but no change.

Any advice will be appreciated

Thanks,
Daniyal Motan