Register ESP32-WROVER

Hi,
I am trying to register a WROVER module.
The registration process never completes.
Tested on HTC Desire 530 mobile android 6.0.

Sorry to hear that,

So with Android devices the BLE support on them can be a little bit hit or miss especially before version 7.0 of Android. We do test with other Android devices running 6.0 but not that particular model. We will check to see if we have a similiar model of device to test this on our end.

Couple of question I would like to ask.

1.) Do you get stuck on the provisioning page and have to completely kill the app?
2.) Have you been able to try provisioning with another device?

The first question is to check to see if maybe the BLE stack on your Android device locked up because eventually our app will give up trying to provision the device. The second question is just to make sure that it is the app and not the embedded device, but I would bet that another device running the app would be able to provision.

Another trick is sometimes on Android devices turning off the bluetooth and turning it back on helps get it to connect to device (or just restarting the whole device).

Hi Kieron,
1.) Do you get stuck on the provisioning page and have to completely kill the app?
Yes.I killed all BLE apps and restart several times.
2.) Have you been able to try provisioning with another device?
Yes, but the other device is an old Nexus 4.
I will try to register on IOS later.Thanks for feedback.

Hi all,
I registered my ESP32-WROVER using IOS on ipad mini tablet.