SensorTile Programming Issue

I have a SensorTile and android phone. I am trying to connect them and send the sensor data to the cloud. I followed the instructions on the Getting Started with SensorTile under the documentation, but the firmware is not automatically updated on my sensor tile. I have the Atmosphere Agent downloaded and it shows up in the bottom right of my taskbar. I also tried downloading the .bin file and using ST-Link Utility to flash the sensor tiles memory. This had no effect. As far as I can tell I have followed all the steps from the written and video recordings. I’m using the Nucleo-F401RE to program the sensor tile.

I have personally had issues getting the ST SensorTile to program consistently. I would double check to make sure the tile is seated really well into it’s cradle and that the nucleo board’s jumpers are in the correct position.

I will give programming one a shot on my end and see how well it works out at my desk.

So far I have not had issues programming the SensorTile. I used ST’s STm32CubeIDE to program the sensors and had no issues. I could connect to the SensorTile with my phone using Bluetooth. My only issue came when I tried to use the cloud logging features on the ST Ble Sensor app.

The firmware atmosphere generates is not compatible with ST’s Ble Sensor app. The ST’s BLE Sensor App only works with the specific out of the box firmware provided by ST not Atmosphere IoT.

You can use the Atmosphere IoT app to connect to the device by navigate to the device in the app and clicking on the “App View” which you’ll then see the BLE icon in the bottom right flashing indicating it’s trying to establish a connection wit h the device. It’s connected when the icon turns solid. You can then in your project’s Application tab build the UI you want to put there to display information.

https://platform.atmosphereiot.com/#{"location"%3A"ProjectEditor"%2C"projectExample"%3A"SensorTile%20Demo.atmo"}

You can take a look at this example project. It has a very basic UI to display the sensor data as it’s collected over BLE

I tried using the demo project, but I can’t find the SensorTile when I try to add a device in the Atmosphere IoT app. I compiled the demo project and downloaded the .bin file. After that, I used ST-Link Utility to flash the memory. I have Atmosphere Agent downloaded already. Is there another way to program the SensorTile with the firmware?

The Getting Started guide says to use these steps below, but I do not know where the ST Nucleo Board’s mounted driv is on my computer.

  1. While the Embedded tab is active, click the Program Firmware button from the tab’s toolbar. This will download the .bin file.
  2. Locate the downloaded file on your computer, and move it into the ST Nucleo board’s mounted drive.
  3. After around 20 seconds of programming, the ST Nucleo board will remount itself and your project will begin running on the SensorTile.